Google PlusFacebookTwitter

On a wing and a Prayer one RAM module…

By on Jul 30, 2007 in Tech Takes | 2 comments

Share On GoogleShare On FacebookShare On Twitter

I had a really bad time yesterday. Today was our computer science Monday test at school (I definitely screwed up, as usual), for which I was preparing yesterday. Rather, I was gonna upload the assignment solutions for the chapter on pointers in C++. That’s when my nightmare started…

I was just going to post on Blogger.com when Firefox crashed, a strange thing to happen on Linux. I started Firefox again, and chose to restore my session. Another crash within 15 seconds. I tried to restore session again…and get this, my OS, yes, Linux, hung. Now that’s a very very rare event indeed – even if an application hangs on Linux (which again is rare), then you still have control over your desktop environment to use the system monitor to kill the process in a jiffy. In my case, it was total – no response from keyboard OR the mouse. And then, my desktop started going bonkers – some of the icons started changing to a different theme, while the others stayed in the default; half of my panel was in one theme, and the other half in something else. With no sign if recovery, I hit the power button.

Now I’ve done unclean shut-downs like this so MANY times using Linux – multiple distros too (including Freespire, Fedora, RHEL, SuSe, Ubuntu etc), and never had an issue. Next boot up the OS always checks for errors and never an issue. This time, it was not gonna be the case.

When I’d hit the power button, then reset, my system hung at the BIOS screen for about a minute, which it never does. I hit reset again, and this time it went on till the Grub boot loader, took a long time to load, and then Ubuntu started its recovery procedure. It immediately hit a brick wall and ran into a stream of errors, and got stuck at one point. I let it be for about 42 seconds, and hit reset again.

This time, it didn’t even boot! The CPU was getting power, but no sign of any booting! I opened my cabinet, checked the connections – everything secured – reset the CMOS, even gave the bloody thing a shaken-not-stirred martini. Still, no boot up. At this point, I was really paranoid of something really really nasty having happened to my computer. The thought of NOT being able to use it for at least a few days? Brrr, scary! As Vivek said, “This is the place where all Code Warriors’ expertise ends, and the guys at Nehru Place come in.”

Fast forward to the next day. I’ve a bad experience to tell about HCL’s service, but I’ll keep that in a separate post. For now, it’ll suffice to know that I got really irritated after coming from school on Monday and started doing random stuff. At one point, I pulled out one of my RAM modules. I have two 256 MB RAM modules. And voila! When I tried to boot one of those less, it worked! I checked my BIOS setup for anything wrong, and then proceeded. Ubuntu did the system check and proceeded as usual. I then tried out various combos of swapping and leaving the RAM modules inside to see, and I definitely say one of them’s gone to that place up in the sky where retired computer components live.

The net result is that my system works now, albeit it’s a bit slower. I’m also guessing there’s some problem with my other RAM module, because instead of showing 256 MB which it used to earlier, it’s showing 180 MB now. I still have to rant about HCL, but that’s in the next post because I’ve to write quite some stuff.



2 Comments

  1. Abhishek Nandakumar

    July 30, 2007

    Post a Reply

    Customer support in India depends largely on your luck. If you’re lucky, you get to talk to someone who’s got a fairly decent amount of knowledge.

    MTNL by far has the worst support.

    HCL is a $4bn dollar company not because of small customers like you and me. It’s mostly because of great AMC contracts they offer. Also, their corporate call centres are much better. I know because my dad calls them quite often at work.

    I hope you’re UPS is not connected to a socket that runs on an inverter when there’s no electicity. I blew up my SMPS twice and RAM module once before realising this was the cause. I switched to a power socket immediately and I haven’t had a problem ever since.

  2. GQ

    August 8, 2007

    Post a Reply

    @Abhi: Eeks, thanks for the advice on the inverter thing. Anyway, customers should at least get some support, even if they’re small ones!

Submit a Comment

Your email address will not be published. Required fields are marked *